This project has moved and is read-only. For the latest updates, please go here.

[Solved] Updates require admin rights

Topics: Publishing Issue
Oct 1, 2013 at 12:25 PM
Hello,

that's me again, got another trouble,
maybe someone can help.

New versions of Flash and Java are not installing,
Previous versions of them with same settings had no problems.
Now there is in log:

The following updates are downloaded and ready for installation. To install the updates, an administrator should log on to this computer and Windows will prompt with further instructions: - Java 7 Update 40 - Adobe Flash Player 11.8.800.175 ActiveX

Therefore, Java is installing under admin account and thru "install updates and shutdown" procedure; Flash keeps saying "error" during sus install with error code 0x80070667 (but I'm using same parameters as before, tried another, no result). Manual Flash install from this same packet goes ok without errors.
Oct 1, 2013 at 12:32 PM
Looks like problem with Flash is in this:

2013-10-01 15:25:26:330 852 3a4 Handler MSI final command line: /qn ALLUSERS=1 REBOOT=REALLYSUPPRESS

I haven't added "ALLUSERS=1 REBOOT=REALLYSUPPRESS"
How can they be removed?

Still do not get about users and admin rights.
Oct 1, 2013 at 9:35 PM
Hi,
The following updates are downloaded and ready for installation. To install the updates, an administrator should log on to this computer and Windows will prompt with further instructions: - Java 7 Update 40 - Adobe Flash Player 11.8.800.175 ActiveX
Please check that this GPO is active :

Image
I haven't added "ALLUSERS=1 REBOOT=REALLYSUPPRESS"
Wsus have automatically add these settings to ensure the installation run silently.
How can they be removed?
This is not possible.

Error code 0x80070667 mean there is a problem with the MSI command line. What do you have set as command line ?
Oct 2, 2013 at 9:33 AM
Hmm.

Recieving update notification for users is disabled, this is company policy. I'm really not sure why updates may need this and why previous versions have installed properly without enabling this option.

About msi command-line, i have tried /q, /qn (this is official command line from Adobe guide), /quiet and nothing, same effect.
Oct 2, 2013 at 10:16 AM
About msi command-line, i have tried /q, /qn (this is official command line from Adobe guide), /quiet and nothing, same effect.
As Wsus will add automatically the '/qn' Command Line, you don't have to add it. Otherwise it will have twice this parameters and generate an error.
Oct 8, 2013 at 10:12 AM
Oh. Got it, it's really my bad. Testing computers were in another NT group.

Thanks a lot for wasting your time to miserable me ((
Marked as answer by DCourtel on 10/8/2013 at 3:41 AM