[Solved] Erreur lors du déploiement de l'ActiveX de Flash

Topics: Configuration Issue
Oct 16, 2013 at 8:33 AM
Bonjour,

j'ai déjà commencé à évoquer ce sujet dans un autre topic (https://wsuspackagepublisher.codeplex.com/discussions/461631) mais peut être que pour plus de clarté, je devrais créer un sujet à part entière.

Sur une 20aine de postes pilotes, je tente d'installer le contrôle ActiveX de la dernière version de Flash Player. C'est la 1ière fois que je déploie celui-ci avec WPP.

J'ai 15 postes OK et 5 en échec (depuis plusieurs jours).
Sur les postes en echec, je récupère le fichier FlashInstall.log (dans c:\WINDOWS\system32\Macromed\Flash du poste).

Et alors là .... :D
ils n'ont pas tous les mêmes logs. Je précise notamment que j'ai déployé le "plugin" Flash dans le même temps (avec aucun poste en echec par contre, woohooo).

Les logs m'indiquent ceci :
1.

[...]
0010 [W] 00001100
=X====== M/11.8.800.94 2013-07-24+14-53-53.761 ========

=O====== M/11.9.900.117 2013-10-14+06-55-01.865 ========
0000 [I] 00000010 "C:\WINDOWS\TEMP\InstallPlugin_11_9_900_117.exe" -install -msi
0001 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/Version 2
0002 [W] 00001036 Software\Macromedia\FlashPlayerPlugin/PlayerPath 2
0003 [I] 00000020 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0004 [W] 00001037 SOFTWARE\MozillaPlugins\@adobe.com/FlashPlayer/ 2
0005 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player Plugin/ 2
0006 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2
0007 [W] 00001036 Software\Opera Software/Last CommandLine 2
0008 [W] 00001036 Software\Opera Software/Last CommandLine 2
0009 [W] 00001036 Software\Opera Software/Plugin Path 2
0010 [W] 00001036 Software\Opera Software/Plugin Path 2
0011 [I] 00000014 C:\WINDOWS\system32\Macromed\Flash\NPSWF32_11_9_900_117.dll
0012 [I] 00000015 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_Plugin.exe
0013 [I] 00000024 C:\WINDOWS\system32\Macromed\Flash\plugin.vch
0014 [I] 00000017 C:\WINDOWS\system32\Macromed\Flash
0015 [I] 00000019 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0016 [W] 00001024 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl 183
0017 [W] 00001024 C:\WINDOWS\system32\FlashPlayerApp.exe 183
0018 [I] 00000021 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe
0019 [W] 00001024 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe 183
0020 [I] 00000012
=X====== M/11.9.900.117 2013-10-14+06-55-05.271 ========

Remarque : Je ne vois ici aucune trace des logs d'install de l'activeX; juste du plugin...

Pour un second poste :
  1. [...]
    =X====== M/11.6.602.171 2013-10-09+08-18-29.848 ========
2013-10-11+22-1-58.398 [error] 1226 1062
=O====== M/11.9.900.117 2013-10-11+22-01-54.631 ========
0000 [I] 00000010 "C:\WINDOWS\TEMP\InstallPlugin_11_9_900_117.exe" -install -msi
0001 [I] 00000020 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0002 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2
0003 [W] 00001036 Software\Mozilla\MaintenanceService\extensions/Plugins 2
0004 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2
0005 [W] 00001036 Software\Opera Software/Last CommandLine 2
0006 [W] 00001036 Software\Opera Software/Last CommandLine 2
0007 [W] 00001036 Software\Opera Software/Plugin Path 2
0008 [W] 00001036 Software\Opera Software/Plugin Path 2
0009 [I] 00000014 C:\WINDOWS\system32\Macromed\Flash\NPSWF32_11_9_900_117.dll
0010 [I] 00000015 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_Plugin.exe
0011 [I] 00000024 C:\WINDOWS\system32\Macromed\Flash\plugin.vch
0012 [I] 00000017 C:\WINDOWS\system32\Macromed\Flash
0013 [I] 00000019 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0014 [W] 00001024 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl 183
0015 [W] 00001024 C:\WINDOWS\system32\FlashPlayerApp.exe 183
0016 [I] 00000021 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe
0017 [W] 00001106
0018 [W] 00001106
0019 [W] 00001024 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe 183
0020 [I] 00000012
=X====== M/11.9.900.117 2013-10-11+22-01-58.445 ========

Remarque : Même remarque que pour l'autre. Il n'y a qu'une trace du plugin pas de l'activeX. Et en plus indiqué en Erreur alors que WPP me dit que c'est OK.


3.Troisième poste :

[...]=X====== M/11.0.1.152 2013-09-27+07-52-18.509 ========

=O====== M/11.9.900.117 2013-10-10+22-01-18.727 ========
0000 [I] 00000010 "C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.exe" -refreshIEElevationPolicies
=X====== M/11.9.900.117 2013-10-10+22-01-19.586 ========

=O====== M/11.9.900.117 2013-10-10+22-01-18.742 ========
0000 [I] 00000010 "C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.exe" -refreshIEElevationPolicies
=X====== M/11.9.900.117 2013-10-10+22-01-22.336 ========

=O====== M/11.9.900.117 2013-10-10+22-01-18.742 ========
0000 [I] 00000010 "C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.exe" -refreshIEElevationPolicies
=X====== M/11.9.900.117 2013-10-10+22-01-22.508 ========

=O====== M/11.9.900.117 2013-10-10+22-01-18.742 ========
0000 [I] 00000010 "C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.exe" -refreshIEElevationPolicies
=X====== M/11.9.900.117 2013-10-10+22-01-22.508 ========

=O====== M/11.9.900.117 2013-10-10+22-01-15.102 ========
0000 [I] 00000010 "C:\WINDOWS\TEMP\InstallAX_11_9_900_117.exe" -install -msi
0001 [I] 00000020 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0002 [I] 00000013 C:\WINDOWS\system32\Macromed\Flash\Flash32_11_9_900_117.ocx
0003 [I] 00000015 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.exe
0004 [I] 00000016 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.dll
0005 [I] 00000023 C:\WINDOWS\system32\Macromed\Flash\activex.vch
0006 [I] 00000019 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0007 [W] 00001024 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl 183
0008 [I] 00000021 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe
0009 [I] 00000012
=X====== M/11.9.900.117 2013-10-10+22-01-25.149 ========

2013-10-11+22-1-23.541 [error] 1226 1062
=O====== M/11.9.900.117 2013-10-11+22-01-16.697 ========
0000 [I] 00000010 "C:\WINDOWS\TEMP\InstallPlugin_11_9_900_117.exe" -install -msi
0001 [I] 00000020 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0002 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2
0003 [W] 00001036 Software\Opera Software/Last CommandLine 2
0004 [W] 00001036 Software\Opera Software/Last CommandLine 2
0005 [W] 00001036 Software\Opera Software/Plugin Path 2
0006 [W] 00001036 Software\Opera Software/Plugin Path 2
0007 [I] 00000014 C:\WINDOWS\system32\Macromed\Flash\NPSWF32_11_9_900_117.dll
0008 [I] 00000015 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_Plugin.exe
0009 [I] 00000024 C:\WINDOWS\system32\Macromed\Flash\plugin.vch
0010 [I] 00000017 C:\WINDOWS\system32\Macromed\Flash
0011 [I] 00000019 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0012 [W] 00001024 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl 183
0013 [W] 00001024 C:\WINDOWS\system32\FlashPlayerApp.exe 183
0014 [I] 00000021 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe
0015 [W] 00001106
0016 [W] 00001106
0017 [W] 00001024 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe 183
0018 [I] 00000012
=X====== M/11.9.900.117 2013-10-11+22-01-23.572 ========

Remarque : On voit bien une trace du contrôle ActiveX mais pas d'erreur.

Dans tous les cas les fichiers de logs ont une date de dernière modification au 12/10 alors que la tentative d'installation se fait tous les jours. Peut être est-ce un problème coté Package WSUS mis à dispo sur le poste de l'utilisateur du coup ?
A quel endroit est stocké ce package ?


Merci
Oct 16, 2013 at 8:41 AM
Ah oui et c'est toujours utile; si je prends un poste qui marche, voici le fichier de logs :

[...]
=X====== M/11.8.800.94 2013-10-10+14-33-47.427 ========

2013-10-11+7-46-3.363 [error] 1226 1062
=O====== M/11.9.900.117 2013-10-11+07-45-58.431 ========
0000 [I] 00000010 "C:\WINDOWS\TEMP\InstallAX_11_9_900_117.exe" -install -msi
0001 [W] 00001036 Software\Macromedia\FlashPlayerActiveX/PlayerPath 2
0002 [I] 00000020 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0003 [W] 00001037 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Adobe Flash Player ActiveX/ 2
0004 [I] 00000013 C:\WINDOWS\system32\Macromed\Flash\Flash32_11_9_900_117.ocx
0005 [I] 00000015 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.exe
0006 [I] 00000016 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_ActiveX.dll
0007 [I] 00000023 C:\WINDOWS\system32\Macromed\Flash\activex.vch
0008 [I] 00000019 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0009 [W] 00001024 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl 183
0010 [W] 00001024 C:\WINDOWS\system32\FlashPlayerApp.exe 183
0011 [I] 00000021 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe
0012 [W] 00001106
0013 [W] 00001106
0014 [W] 00001024 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe 183
0015 [I] 00000012
=X====== M/11.9.900.117 2013-10-11+07-46-03.394 ========

2013-10-14+6-51-13.250 [error] 1226 1062
=O====== M/11.9.900.117 2013-10-14+06-51-02.796 ========
0000 [I] 00000010 "C:\WINDOWS\TEMP\InstallPlugin_11_9_900_117.exe" -install -msi
0001 [I] 00000020 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0002 [W] 00001036 Software\Mozilla\Firefox\extensions/Plugins 2
0003 [W] 00001036 Software\Mozilla\MaintenanceService\extensions/Plugins 2
0004 [W] 00001036 Software\Mozilla\Mozilla Firefox\extensions/Plugins 2
0005 [W] 00001036 Software\Opera Software/Last CommandLine 2
0006 [W] 00001036 Software\Opera Software/Last CommandLine 2
0007 [W] 00001036 Software\Opera Software/Plugin Path 2
0008 [W] 00001036 Software\Opera Software/Plugin Path 2
0009 [I] 00000014 C:\WINDOWS\system32\Macromed\Flash\NPSWF32_11_9_900_117.dll
0010 [I] 00000015 C:\WINDOWS\system32\Macromed\Flash\FlashUtil32_11_9_900_117_Plugin.exe
0011 [I] 00000024 C:\WINDOWS\system32\Macromed\Flash\plugin.vch
0012 [I] 00000017 C:\WINDOWS\system32\Macromed\Flash
0013 [I] 00000019 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl
0014 [W] 00001024 C:\WINDOWS\system32\FlashPlayerCPLApp.cpl 183
0015 [W] 00001024 C:\WINDOWS\system32\FlashPlayerApp.exe 183
0016 [I] 00000021 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe
0017 [W] 00001106
0018 [W] 00001106
0019 [W] 00001024 C:\WINDOWS\system32\Macromed\Flash\FlashPlayerUpdateService.exe 183
0020 [I] 00000012
=X====== M/11.9.900.117 2013-10-14+06-51-13.359 ========
Coordinator
Oct 16, 2013 at 9:40 AM
Bonjour, ci tu veux forcer un poste à re-télécharger la mise à jour, le mieux c'est de supprimer le répertoire "C:\Windows\SoftwareDistribution\Download"
Marked as answer by DCourtel on 1/17/2014 at 8:12 AM
Oct 16, 2013 at 12:34 PM
Merci pour ta réponse David (allez je fais le pari que c'est ton prénom ;p)

J'ai supprimé le contenu du dossier Download; j'attends de voir ce soir ce qu'il se passe. (Je n'arrive pas à pousser l'installation du package sans devoir attendre même via le "Install this update..."; en regardant le WindowsUpdate.log il me dit que le package sera installé ce soir à minuit.

Autrement, petit hors sujet mais identification d'un léger "bug".

Quand on affiche un package; et qu'on a choisi de classer les informations dans l'onglet Status", le tri demandé ne s'applique pas lorsque l'on sort de ce package et qu'on y retourne.

Par exemple si je sélectionne un package et le tri dans l'onglet Status par la colonne "Status", celle-ci n'est pas prise en compte si je sors de ce package pour y retourner aussitôt; bien que la petite fléche de tri soit indiquée sur cette colonne. Il faut alors cliquer deux fois pour avoir le tri. C'est un détail mais voila c'est remonté =)
Coordinator
Oct 16, 2013 at 2:21 PM
Merci pour ta réponse David (allez je fais le pari que c'est ton prénom ;p)
C'est le début de la célèbrité :-)
Je n'arrive pas à pousser l'installation du package sans devoir attendre même via le "Install this update..."
Les postes ne seraient-ils pas configuré pour "Signaler sans télécharger" les nouvelles mises à jour ?
Autrement, petit hors sujet mais identification d'un léger "bug".
Je l'ai remarqué aussi et c'est vrai que c'est énervant. Il faut que je regarde ca.
Oct 17, 2013 at 10:03 AM
Re,
les postes sont configurés pour "4 - Télécharger et planifier l'installation".

Concernant le flash, j'ai un peu tout essayé mais sans succès ...
A savoir :
supprimer le contenu du dossier "C:\Windows\SoftwareDistribution\Download";
supprimer le contenu du dossier Systeme32\Macromed\Flash

Pour l'instant rien n'y fait !
Oct 17, 2013 at 11:17 AM
Bon, je pense avoir trouvé en lancant l'install localement depuis le poste.

Il y a une clé de registre à supprimer :
hkey_local_machine\software\classes\installer\products\00B86459180C72B 4CA69A0A21353E906 (elle fait référence à Flash Player 10).
En la supprimant ca fonctionne; je vais essayer sur les 4 autres postes impactés histoire d'avoir la confirmation.

La question est : Pourquoi sur ces postes et pas d'autres... ? Aucune idée
L'autre question est de savoir comment faire pour automatiser cette suppression de clé.

Tu me confirmes que je ne peux pas ajouter dans le package délivré par défaut la suppression de la clé et qu'il faut que je passe par un "Custom MSI" dans un premier temps pour ensuite envoyer mon package d'installation de Flash11 ? (une installation en deux temps c'est bof quand même).

Merci
Marked as answer by DCourtel on 1/17/2014 at 8:12 AM
Coordinator
Oct 17, 2013 at 1:18 PM
Oui, il faudra faire une custom update pour supprimer la clé de registre et installer Flash player en une seul fois.
Oct 18, 2013 at 9:47 AM
Comment tu fais pour supprimer une clé entière via le Custom Update stp ?
Dans Value je mets quoi ?

Et ensuite, comment lui indiquer de lancer le flash ? Je choisis "Allow to execute a file" ? Si oui j'indique quoi en "Path to the file"; parameters, etc.. ?

Je dois indiquer un "return code" ou ensuite tout est géré comme d'hab ?

Merci
Oct 18, 2013 at 10:03 AM
Un petit bug à noter dans le process de création via Custom Update.
Un clique droit sur "Declare a variable to store..." puis "Delete this element" ne fonctionne pas.

De même quand on tente de monter/descendre un élément de la liste (parfois ca monte tout en haut d'un coup et plus possible de le redescendre par exemple).
Coordinator
Oct 18, 2013 at 7:16 PM
Comment tu fais pour supprimer une clé entière via le Custom Update stp ?
Dans Value je mets quoi ?
Effectivement, le composant 'Registry Value' ne prend en charge que des actions sur des valeurs de clé de registre. Pour le moment, on ne peut pas agir sur les clés en elles mêmes. Ca reste à être ajouté à WPP.
Pour contourner le problème, tu peux te baser sur un script VBS.
Et ensuite, comment lui indiquer de lancer le flash ? Je choisis "Allow to execute a file" ?
Exactement.
Si oui j'indique quoi en "Path to the file"; parameters, etc.. ?
Etant donné que le fichier d'installation de Flash Player sera dans le même répertoire que la custom update, il faut juste indiquer le nom du fichier (par exemple : FlashPlayer11.9.exe) sans nom de répertoire. Par défaut le CustomUpdateEngine va chercher le fichier à exécuter, dans le même répertoire où il se trouve lui même.
Pour le reste ne rien spécifier. Sauf pour "Store Return Code To", là il faut indiquer le nom de ta variable si tu en utilise une.
Je dois indiquer un "return code" ou ensuite tout est géré comme d'hab ?
Oui, N'oublie pas d'ajouter le fichier d'installation de FlashPlayer, une fois que tu est sortie de l'assistant CustomUpdate et que tu est revenu dans l'assistant de création de mise à jour simple.
Coordinator
Nov 7, 2013 at 7:14 PM
Dans la dernière version de WPP, j'ai ajouté la possibilité de travailler avec des valeurs du registre.
Marked as answer by DCourtel on 1/17/2014 at 8:13 AM
Nov 7, 2013 at 9:12 PM
Ah extra merci !

J'avais bloqué le déploiement à cause de ça justement !

Du coup il y a quelque chose de particulier à faire pour faire la MAJ?
Coordinator
Nov 8, 2013 at 4:46 AM
Il faut recréer la mise à jour et inclure une "Custom Action" Registry Value.