This project has moved and is read-only. For the latest updates, please go here.

going stuck in publishing updates for Adobe Reader 11

Topics: Publishing Issue
Nov 12, 2013 at 5:10 PM
Tried to push updates 11.0.04 and 11.0.05 on two testing Win7 pro machines without luck :(

WPP says as status for booth 'not applicable'.

One machine has installed 11.0.0, the other one 11.0.03. I tried it already with updates from catalog subscription and also tried to make my own updates from msp-file.
Nov 13, 2013 at 9:47 AM
Hi,

did you deploy Reader as MUI Version by any chance? Are the msp files matching for the deployed reader version (MUI or not)? Did you put any rules into the msp packages?

Regards
Norbert
Nov 13, 2013 at 10:20 AM
Edited Nov 13, 2013 at 8:42 PM
Hi Norbert,

Reader should not be MUI-version, but Im not shure (where I can see this?). But I think the DE in filename indicates, that they are not MUI-versions.

The following msi and exe are installed on this booth testing machines :
  • AdbeRdr11000_de_DE.msi (48.322KB)
  • AdbeRdr11003_de_DE.exe (49.379KB)
The following msp I use (I can manually update with this two msp booth machines)
  • AdbeRdrUpd11004.msp (18.828KB)
  • AdbeRdrUpd11005.msp (2.620KB)
I use the same msp files in WPP without any rules defined. But both machines say 'No updates available'.

Greetings
Helmut
Nov 13, 2013 at 10:32 AM
Hi,

acutally I got exactly the same Problem lately. How long did you wait? can you try publishing via adobe reader catalog?
Nov 13, 2013 at 10:44 AM
Edited Nov 13, 2013 at 8:43 PM
My first try was to publish this updates from subscribed catalog -> without luck ('not applicable'). I also tried with MUI-msp -> same result.
I waited about 2 days. So I decided yesterday evening to try my own packages with this both msp-files I mentioned above, but same result :(

Have I to define any rules in msp packages?

I tried before with flash-updates on booth machines -> everything worked fine. After a detect and report I could install this packages in Windows Update.
On an other Xp-machine I could also deploy Reader10.1.8 without any problems.

I'll now test, if Adobe Acrobat 10 Pro will update (I hope ;)
Nov 13, 2013 at 10:47 AM
ht104 wrote:
Have I to define any rules in msp packages?
No, but you can define dependencies. Try selecting requirement 11.0.0 for the 11.0.04 update and requirement 11.0.04 for the 11.0.05 update. Maybe this helps.

Bye
Norbert
Nov 13, 2013 at 11:09 AM
Edited Nov 13, 2013 at 11:10 AM
Hi Norbert,

can you explain plz where I can define this dependencies in the packages? I'm an absolutly newbie in WPP.
Nov 13, 2013 at 11:53 AM
Open the update package in WPP for revising (überarbeiten) and tick Prerequisites (Voraussetzungen) ;)
Nov 13, 2013 at 1:47 PM
Edited Nov 13, 2013 at 1:49 PM
Ahhh... Danke!

So I have to check in first the 11.0.0 msi in WPP, right?
Nov 13, 2013 at 2:02 PM
That shouldn't be necessary, but I would do it. ;)
Nov 13, 2013 at 8:16 PM
After publishing 11.0.0.msi and with adviced prerequisites both machines still on status 'not applicable' on updates 11.0.04 and 11.0.05. But both on status 'installed' for 11.0.0.msi.
So I tested further and checked in 11.0.01, 02, and 03 msp.
The machine with installed 11.0.0.0,msi starts to install patch by patch. The machine with installed 11.0.03.exe does nothing - for all updates status 'not applicable'.

So I rolled back installation for the first machine to 11.0.0.msi and testest with 11.0.04.msp with superseeded 03, 02 and 01.msp -> status now here too 'not applicable'.

So I think, there is no chance to get machines updated with WPP where the 11.0.03.exe is installed?
Nov 13, 2013 at 9:25 PM
As per Adobe said, Adobe Reader 11.0.05 only apply on machines with 11.0.04 installed. Adobe Web Site
Adobe Reader 11.0.04 can be applied on machines with Reader 11.0.0 and later.

As you are using .msp files to perform your updates, you should update only computers which have received MSI file to install Adobe Reader.
Meta-data embeded into .msp files can prevent installation on computers that have received Adobe Reader with an EXE file.

If you have successfuly upgraded manually a computer from Reader 11.0.03 to 11.0.04 with a MSP file, then you can try to revise the update, and in the "IsInstallable Rules" tab check the option "Delete Rules at package level", and make your own rules, based on file version.
Nov 14, 2013 at 11:18 AM
Hi,

tried it today: once manually installed 11.0.04 over 11.0.03.exe installation, it works now also updating that machine to 11.0.05 via WPP.

Greetings Helmut
Nov 19, 2013 at 3:39 PM
Hello,

I have exactly the same problem.
Clean systems or systems with previous Adobe Reader version-> install or upgrade to Adobe Reader XI - Polish using MSI via WPP - works great.

When try to distribute 11.0.04 MSP via WPP to Adobe Reader 11.0.00 - always "NOT APPLICABLE".

I tried Helmut's workaround and installed 11.0.04 manually. But, when after trying to distribute 11.0.05 MSP via WPP - still "NOT APPLICABLE".

Something is wrong with Adobe MSP.
The problem with "not applicable" 11.0.0x MSP is mention on other forums (e.g. forums.adobe.com or Local Update Publisher) without clear solution.

Any idea?

Regards,
Jacek
Nov 19, 2013 at 3:54 PM
What worked for me, was, to publish and approve all msp-files in WPP (11.0.01, 11.0.02, 11.0.03 and so on).
Some clients with 11.0.0 installed 'grabbed' first 11.0.01.msp and updated so step by step up to 11.0.05. Others 'grabbed' first 11.0.04.msp (without going the steps 01, 02, 03).
I dont know, why... but works now ;)
Nov 20, 2013 at 10:57 AM
I have tested both paths.
My clients don't grab MSP in any path:
  • nor 11.0.00 MSI -> 11.0.01 MSP,
  • nor 11.0.00 MSI -> 11.0.04 MSP.
    It's very strange when all clients with different history and configuration report "not applicable".
    It seems more probably that there is something wrong with MSP package configuration.
When configure first MSP (11.0.00 or 11.0.04), do you set any supercedes / prerequirements / or anything in page "already installed" / "installable"?

You wrote "once manually installed 11.0.04 over 11.0.03.exe installation, it works now also updating that machine to 11.0.05 via WPP".
What do you mean in "11.0.03 exe installation"?

Regards,
Jacek
Nov 20, 2013 at 7:17 PM
Edited Nov 20, 2013 at 7:18 PM
I too am experiencing this problem. My clients are running Win 7 Pro x64, with Adobe Reader 11.0.03 installed. It's my understanding that 11.0.05 will only upgrade 11.0.04. I've published the 11.0.04 msp, and all of my client computers have reported "Not Applicable." For the fun of it, I've also tried publishing the 11.0.05 msp as well. I get the same result. I have no supersedes, or rules/requirements defined. I basically just created the update, added the msp, input the title and other info, and published. If required, I will be happy to attach logs or whatever. Thanks!

edit : more info... I've tried this process with both the MUI and regular MSP
Nov 21, 2013 at 8:06 AM
Edited Nov 21, 2013 at 8:08 AM
Hi Tata2anka,

let me explain: I had two different kinds of installation in our environment: some of it had installaed Adobe Reader 11 with the major release 11.0.0.msi file, the others had the first installation with 11.0.03.exe file.

So, that I knew, that 11.0.04.msi is installable over both versions, I only published 11.0.04.msp and 11.0.05.msp.
But not one client picked up the 11.0.04.msp - all with status 'not applicable'.

So I published too 11.0.03, 11.0.02 and 11.0.01.msp and approved it in WPP. I also published the major release 11.0.0.msi but NOT approved it.

For all clients (whatever was the stock installation was 11.0.0.msi or 11.0.03.exe) now status for 11.0.0.msi was 'installed', but for some clients (not for all) with 11.0.03.exe all other updates 01,02,03,04,05 was 'not applicable'. For those I had to manually install the 11.0.04.msp - after that was done, they installed automatically 11.0.05.msp via WPP.
The clients that had installed the 11.0.0.msi now installed two different ways (I dont know why): Some of them installed step by step from 11.0.01 to 11.0.05, others only installed 11.0.04 and 11.0.05.

All packages are NOT superseeded! (I tried it too with superseeding 01, 02, 03 in 11.0.04 - but worked not for me!
Nov 24, 2013 at 10:23 PM
Please, delete udpates that appears as 'Not applicable'. Download the latest release of WPP and publish again those updates.
Marked as answer by ht104 on 11/25/2013 at 3:15 AM
Nov 25, 2013 at 9:37 AM
Question to new release: If I copy the new version, do I need a new certificate or can I use the one from previous version?
Nov 25, 2013 at 10:51 AM
New releases doesn't change anything to certificate. Keep the old one.
There is very few reasons to change certificate :
  • Certificate expiration
  • Root Authority certificate expiration
  • Root Authority modifications
  • Compromised certificate
Nov 25, 2013 at 11:14 AM
Thanks for information!