This project has moved and is read-only. For the latest updates, please go here.


Topics: Configuration Issue
Mar 11, 2014 at 6:58 AM
I Approved the correct Driver (model/version) for a DELL BIOS driver , And when I Approve this driver on the correct computer model the update doesnt appear in the WUA, i checked the Windowsupdate.log file and i found that it couldnt evaluate this update as seen below.

2014-03-11 07:13:55:839 952 610 PT +++++++++++ PT: Synchronizing server updates +++++++++++
2014-03-11 07:13:55:839 952 610 PT + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://WSUS:8530/ClientWebService/client.asmx
2014-03-11 07:13:55:941 952 610 PT WARNING: Cached cookie has expired or new PID is available
2014-03-11 07:13:55:941 952 610 PT Initializing simple targeting cookie, clientId = 6768dcea-9bdb-44bb-a806-3b6c27b9c9c0, target group = LAB, DNS name =
2014-03-11 07:13:55:941 952 610 PT Server URL = http://pcrs0141:8530/SimpleAuthWebService/SimpleAuth.asmx
2014-03-11 07:14:01:973 952 610 Agent WARNING: Failed to evaluate Installed rule, updateId = {1A37D14B-2588-469C-A219-FA954F4803B4}.1, hr = 8004100E
2014-03-11 07:14:01:974 952 610 Agent WARNING: Failed to evaluate Installable rule, updateId = {1A37D14B-2588-469C-A219-FA954F4803B4}.1, hr = 8004100E
Mar 11, 2014 at 8:13 AM
Edited Mar 11, 2014 at 8:17 AM
Hi AMElSisi,
Did you use Dell's SCUP Catalog?

I have some Dell updates, which has WMI install rules, like these:
SELECT * FROM Dell_OEMComputerSystem WHERE SystemTypeID = '630'
You can see that it is using some odd WMI Dell WMI namespace, if I am correct, you can only get this, by installing Dell OpenManage Inventory Agent (DSIA).
Dell OpenManage Inventory Agent is available in the Dell Catalog, but it also uses the Dell WMI installable rules, you can revise that update, and change the installable rule to something like this:
select * from win32_ComputerSystem WHERE Model like 'OptiPlex%'
I have not been successful with installing BIOS updates yet, but I think we're close.
When Dell OpenManage Inventory Agent is installed, it should create the WMI namespace on startup and then stop the service, or something like that.
Mar 11, 2014 at 12:12 PM
Thanks NikolajP for your response , from your words does this mean that'll never install dell updates from catalog without installing the DSIA ?
Mar 11, 2014 at 12:26 PM
You may want to read this Article

It's in German, but Google Translate can help :-)
Marked as answer by DCourtel on 5/8/2014 at 2:52 AM
Mar 11, 2014 at 2:08 PM
Thanks DCourtel , gonna try it , Really Many Thanks for your support :)
Mar 11, 2014 at 10:11 PM

let me know if you need more info. ;) Regarding BIOS Installation, there are some "older" bios packages, which have the wrong "silent" Switch defined. So try using it Manual before deploying it.

Mar 12, 2014 at 5:11 AM
Sure NorbertFe, but Actually Am still stuck with the "Dell OpenManage Inventory Agent" as when i push it via WPP it is evaluated as not needed Although AM testing on a Dell Machine , but What i found in the installable rule that it requires Windows Version 5 And below , And Am using Windows 7 sp1 which is 6.*
Mar 12, 2014 at 10:20 AM
What type of Dell machine is it?
Mar 12, 2014 at 12:17 PM
Edited Mar 12, 2014 at 12:28 PM
Optiplex 780, I guess NorbretFE it wasnt matching because of the Windows Version specified in the installable Rule
Mar 12, 2014 at 2:10 PM
All , I modified the Installable Rule for the Dell Agent to
WMI Query "root\CIMV2
select * from win32_ComputerSystem WHERE Model like 'OptiPlex%'"

Now I have the Agent installed, I Also made a restart twice , I Published the BIOS update that I needed since the beginning were I checked the correct Model/Version of the BIOS update , when i run /detectnow from the client side i still get that the update cannot be evaluated as shown in my first post and as if the Agent is not installed :S