This project has moved and is read-only. For the latest updates, please go here.

[Solved] Show Pending Updates Firewall problem

Topics: Configuration Issue
Jul 1, 2014 at 12:30 PM
Hi,
I have a strange behavior. I enabled with the GPO the remote administration as also mentioned in this thread , but still Show Pending Updates doesn't work. In the client Firewall I can see the DCOM exceptions. So Report Now, Dectect Now, Show Current Logon User and Restart PC is working only Show Pending Updates and Install Pending Updates are not working.
What I made wrong?
THX for your help
Jul 1, 2014 at 9:14 PM
Hi, try the feature and once it has failed, go to %temp% and send me the file WPP-GUID.log to package.publisher@free.fr
Sep 3, 2014 at 1:37 PM
Hi together,
Did you resolve the problem? I have the same issue.
Sep 3, 2014 at 7:51 PM
Did you try with disabled firewall to see if it's really a security Policy issue ?
Sep 4, 2014 at 8:22 AM
Hi,

when firewall ist disabled, show pending and install pending work.
Sep 5, 2014 at 10:00 PM
Marked as answer by DCourtel on 9/13/2014 at 12:03 PM
Sep 8, 2014 at 8:38 AM
DCourtel wrote:
Please see this doc : Firewall Rules for Remote Administration
Thank you so much! Works fine now!

Was this the missing document which you couldn't upload at codeplex?

You do a great job here!
Oct 1, 2014 at 10:30 PM
Edited Feb 16, 2015 at 6:38 PM
Hello everyone,

according to all previous posts of this thread my issue is nearly the same BUT only with Windows XP SP3!

When choosing Show Pending Updates the firewall error message occurs. Turning XP-Client firewall off it works.

The deployed GPO based on that discussion Which ports to open in firewall and of course that PDF: Firewall Rules for Remote Administration.

Could it be that both port-rules within the GPO shown in the PDF are only valid for Windows 7? If not what other mistakes could it be?


Thanks for Your help and keep on with this marvellous programme!

Best regards
Petapico.
Feb 16, 2015 at 8:28 PM
I don't think that OS on client computer make a difference.
May be, check if DCom is enable these clients.
Feb 19, 2015 at 1:00 PM
Hello DCourtel,

thanks for Your quick reply.

We will test Your suggestion and post the results here.

Best regards
Petapico.
Feb 19, 2015 at 4:31 PM
Edited Feb 19, 2015 at 4:56 PM
After testing we found this:

We used the GPO of 2008 R2 with the entry
Windows Firewall with Advanced Security 
which Windows XP does not accept.

We replaced that 2008 R2 GPO and added this GPO:
Computer - Admin. Templates - Network Connections - Windows Firewall: Define inbound program exceptions
%WinDir%\System32\dllhost.exe:NNN.NN.NNN.NNN:enabled:DLLHost
Thanks to all supporter!

Best regards
Petapico.