This project has moved and is read-only. For the latest updates, please go here.

Client`s workstation not see published updates. Please Help!

Topics: Publishing Issue
Oct 17, 2014 at 8:25 AM
Edited Oct 17, 2014 at 8:27 AM
Hello,

Ive already installed and configured WPP. Certificate was published and add to group policy, firewall rules also were configured. Then Ive setuped test virtual workstation. First Ive tried to publish tightVNC and this application was successfully published,detected by test workstation and installed. Then Ive tried to publish Adobe Reader XI. Ive downloaded Polish version 11.0.0 from Adobe FTP and published it with deployment instruction from this site. Test workstation also detected this update and succesfully instaled it. Then Ive tried to publish update 11.0.09 for Adobe Reader XI. Ive also configured and published update. But Status for this update was Not applicable. Ive tried to invistigate this problem and found the solution that need to add processor architecture in rules window. Ive added this options, update changed status for this workstationfrom Not applicable no Not installed, but workstation still not detected this update. Then I have tried any combinations of rules for this update. But nothing changed and at the end I have reinstalled virtual machine but dont changed published applications like vnc and adobe reader xi and update for it. But yesterday this new virtual machine dont detect any updates. Also vnc that worked before.. Today I power on virtual machine and it see TightVNC, but not detect Adobe Reader XI .. In the WPP console Adobe Reader XI 11.0.0 has status Not Installed for this workstation. This update already approved.. The update 11.0.09 not approved and has status not applicable. At the second window of rules: "Indicate here the rule or rules that allow clients computer to determine if the update is installable." Ive add processor architecture for x86 and x64 ( Is it possible in the future add feature for x86/x64 systems to select in this case?)
So I don
t know what to do now.. How to check what can blocking detect update for Adobe Reader? Why workstation can`t detect original adobe reader 11.0.0 that was published and worked before.. and also how to resolve problem with not applicable status for adobe reader update?
When I try to install 11.0.09 from msp file it successfully installed on test workstation.. Is I need to check superseed for published adobe reader 11.0.0 in the 11.0.09 update settings?

If you need any logs or screenshots I can paste it here
Oct 17, 2014 at 10:01 AM
Recreated update for adobe reader 11.0.0 from mui installer downloaded from adobe ftp. Workstation is online in WPP. Sent Ping, sent detect. Worksatation changed status from unknown to Not installed for this update. Ive approved update and workstation still not detect this update in Windows Update. In pending updates only tightvnc that I have not installed yet... I dont know what to do..
Oct 17, 2014 at 10:38 AM
After some investigations I found that in WSUS Console this update had status approved but not benn downloaded yet..
The Ive restarted WSUS Service and checked in WSUS console the status again. Now update is approved and test workstation detected this update in WU :)

Ok. let
s try to install vnc and reader 11.0.0. Then will try to publish update 11.0.09 for reader again :)
Oct 17, 2014 at 11:33 AM
It works now! But I think that it is a bug that I need start WSUS service every time when workstation has a problem with updates detect.
because when i try to stop WSUS service from console I recieve an error that service is not running. Then I start service, go to test workstation and checking for new updates. And after this manipulations Windows Update successfuly detect new updates
Oct 17, 2014 at 3:35 PM
Do you see any error message in the C:\Windows\WindowsUpdate.log
Oct 17, 2014 at 3:55 PM
Edited Oct 17, 2014 at 4:28 PM
DCourtel wrote:
Do you see any error message in the C:\Windows\WindowsUpdate.log
It is works now..

Could you help me with two other problems?

First one is that after adobe reader is installed from wsus i have not any shortcuts for Adobe reader... When I check msi package in Adobe customization wizard I see two shortcuts: one on desktop and the second in start menu -> programs
How can resolve this problem? My test workstation has Windows 7 x64 system

The second problem, I don`t know how to deploy customized version of reader 11.0.0 for clients which already has installed any other versions of Adobe Reader 11.x.x manually.. Is it possible to create some rules to remove adobe reader if for example adobe auto update is installed and then install customized version from wsus?