.net 4.0 Framework Client + Extended

Topics: Publishing Issue
Nov 14, 2014 at 11:14 AM
Edited Nov 14, 2014 at 11:16 AM
Hi everybody,

I searched for a method to install .net Framework 4.0 on Windows 7 Clients for a software which I push with a GPO. This Software (Viscosity for VPN) requires .net 4.0 Framework.

I tried to make a MSI-File out of the .net Exe. But it didn't worked. I also found the answer in the internet, that you can't install .net 4.0 via GPO.

So I made a Start up Script which is working, but that's not a satisfied method. So I went on with my search and found the WPP.

The installation was directly on the WSUS succesful. I tried to create a "custom update" - but always when I push it to the WSUS and let the WSUS pushing it out, my Test Client which tries to install the update is failing.

Windows Update just says "Failure Code FFFC".

I'm not sure what you need, here is my XML which belongs to this custom update package:


<CustomUpdate>
<Action>
<ElementType>CustomUpdateElements.ExecutableElement</ElementType>
<PathToExecutable>C:\Program Files\WSUS Package Publisher\dotNetFx40_Full_x86_x64.exe</PathToExecutable>
<Parameters>/q /norestart</Parameters>
<KillProcess>True</KillProcess>
<TimeBeforeKilling>10</TimeBeforeKilling>
<Variable/>
</Action>
</CustomUpdate>



Any suggestion? I hope you can help me out, I'm tired of searching another method for deploying that .net....

Greetings



EDIT:
I also created a GPO with the two Cert's succesfully. Certification is IMHO not the problem.
Editor
Nov 14, 2014 at 12:57 PM
.Net Framework 4.0 is in WSUS available. In http://support.microsoft.com/kb/2492172/de you will find it in the middle. You have to activate Feature Packs in your WSUS.
And after Installation Clients will report back to your WSUS what Security Updates they want.
Coordinator
Nov 14, 2014 at 2:56 PM
For .NET Framework 4.0, it's KB982671
By the way, code 'FFFC' mean, file not found.
<PathToExecutable>C:\Program Files\WSUS Package Publisher\dotNetFx40_Full_x86_x64.exe</PathToExecutable>
'PathToExecutable' refers to the folder where CLIENTS COMPUTERS will find the EXE to execute. I'm pretty much sure that 'C:\Program Files\WSUS Package Publisher' is not present on clients computers !!!
You should include this file in the update package. So, it will be available for clients, in the same directory than the update itself.
the parameter should, then be : <PathToExecutable>dotNetFx40_Full_x86_x64.exe</PathToExecutable>
because the file is in the same directory than CustomUpdateEngine
Nov 14, 2014 at 3:44 PM
Hey dudes,

awesome, thanks for your replies!

I activated the Feature Packs in WSUS, but there are no Updates/Packs under "Feature Packs". Do I have to do more, that there is shown something? I guess that's also the point, why I'm still not finding KB982671 there.

Thanks in advice and regards
Editor
Nov 14, 2014 at 3:46 PM
Did you synchronize after activation Feature Packs? If no, pls synchronize one time manually. After this, have a look in Feature Packs again.
Marked as answer by WinfriedSonntag on 11/14/2014 at 9:18 AM
Nov 14, 2014 at 4:00 PM
Awesome, I got it!

Thank you very much and have a nice weekend. :-)
Nov 14, 2014 at 4:11 PM
Well, I think I was too early with being happy....

I See the update, I allowed it for my testgroup. I allowed the .net 4.0 for Windows 7 x86 and x64.

But my Client in this group does not show me this update... Hm any suggestions?

Regards
Nov 14, 2014 at 4:16 PM
Well however, no it's there and get's installed.. I just searched for the 5th time and pushed it on WSUS for 5th time...
Editor
Nov 14, 2014 at 4:17 PM
Is the update downloaded complete? You can see the download status on the Startpage from WSUS:
http://www.wsus.de/images/wsus-version.png

Pls check too the Version from your WSUS, if you have installed the WSUS on a OS <W2012.
http://wsus.de/faq If your Build lower the .274 pls install the Updates.
Editor
Nov 14, 2014 at 4:18 PM
JusT4Los3 wrote:
Well however, no it's there and get's installed.. I just searched for the 5th time and pushed it on WSUS for 5th time...
It take some time for download. ;)
Nov 14, 2014 at 4:20 PM
Thank you for your very helpful instructions! Keep on!