This project has moved and is read-only. For the latest updates, please go here.

[solved] Publishing msp: An error occurred while checking the meta data

Topics: Publishing Issue
Jan 7, 2015 at 10:49 AM

we try to publish a (3rd party) msp, but we get the error

__An error occurred while checking the meta data of the file you are trying to publish. This problem occurs mostly in publishing invalid MSI or MSP files.

It is no problem to install the msp manually. The msp can be opened in Orca and browsed through properties without any error.

Is this a known problem / what can we do? Thank you!

PP Version: 1.3.1411.9
Server: 6.3.9600.16384
Jan 7, 2015 at 4:38 PM
Hi, when you publish a MSI or MSP file, wsus check the integrity of metadata against the XML definition for this file. If this error occurs, that mean that metadata Embedded in the MSP file doesn't respect the PatchApplicability Schema

When publishing, WPP shows you metadata (just before clicking on 'Publish'), so you can check it. Once you have tick the checkbox 'Edit Applicability Metadata', you can click on the 'Validate' button and see if any error is presented to you.
Marked as answer by trcc on 1/7/2015 at 11:28 PM
Jan 8, 2015 at 7:28 AM

thank you, you helped me a lot.

For TargetLanuage is Integer needed and there was 0,1033,1031 - I changed it to 1031 only and then it worked.
Jan 8, 2015 at 4:53 PM
Usually, 'TargetLanguage' is the faulty node.