"Not applicable" Adobe Flash

Topics: Publishing Issue
Jan 27, 2015 at 6:03 PM
Edited Jan 27, 2015 at 6:06 PM
I've posted about this before in a closed thread titled "[Solved] "Not applicable" issue."

I cannot publish Flash and Shockwave succesfully, and all my clients show up as "Not applicable" but was able to publish Java 7 71 before that without issues, also was able to publish Flash 14 before that.

For example Flash Player for IE(ActiveX) 16.0.0.257

Tagged as Update, Critical Update.

"IsInstalled" had the product code for Flash for ActiveX 16.0.0.257 in it <msiar:MsiProductInstalled ProductCode="{70f97130-dbf6-4885-854c-cc7a80fc65e1}"/>

"IsInstallable" was <bar:Processor Architecture="9"/> 'OR' <bar:Processor Architecture="0"/>. Also when I choose to add the 'OR' clauseto add the x64 it just puts the rules one by one inside the main AND tag like this:
<bar:Processor Architecture="9"/>
<bar:Processor Architecture="0"/>

Next try was with version 16.0.0.287. This time I did not put any rules in the "IsInstallable" section and got the same "Not applicable" message 3 days after approving it for all clients.

Any thoughts?