This project has moved and is read-only. For the latest updates, please go here.

Deploy some Exe's - Programme verteilen (Exe)

Topics: Publishing Issue, Translation - German
Jul 6, 2016 at 6:57 AM
Hi together,

I would like to publish some small programms e.g. PrintDesktop or FastStoneCapture. All of them are EXEs. So I created the rules and the client see these updates.

Problem I)
If I create a custom update and set the path to the executable (for example: E:\deploy\abcd.exe), the file is unreachable (doesn't exist is standing in CustomUpdateEngine.log). When the file is on a share comes

Problem II)
The update is starting. I can see the customupdate.exe in task manager but it will never come to an end.

So what can I do - what is the problem here?!

Thanks for help,

Belloci

Hallo zusammen,

ich würde gerne kleinere Programme über den WPP bereitstellen. In diesem Falle beispielhaft die Programme PrintDesktop und FastStoneCapture, die als EXE vorliegen. Die Regeln scheinen zu passen, die (Test-)Clients wollen das Update ziehen aber es kommt immer wieder zu Fehlern.

Fehler I)
Sobald ein Custom Update installiert werden soll und ich einen lokalen Pfad auf dem SRV auf dem auch WPP installiert ist angebe, scheint die Datei für den Client nicht erreichbar zu sein. Z.B. E:\deploy\abcd.exe

Fehler II)
Sobald die Exe auf einem Share liegt, scheint es so, dass das Update starten möchte. Es wird aber nie fertig gestellt und automatisch beendet nach den voreingestellt 10 Minuten.

Wo liegt hier der Fehler? Für eine kleine Hilfestellung bin ich dankbar.

Gruß,
Belloci
Jul 6, 2016 at 7:31 AM
Warum als Custom Update? Warum nicht normal einfach zur Verfügung stellen? Oder haben diese Programme keine Installationsroutine, sondern werden einfach nur so ausgeführt? Um helfen zu können, brauchen wir weitere Details.
Jul 6, 2016 at 12:06 PM
Hallo Winfried,

schon viele Threads von dir gelesen und jetzt selbst die Ehre! ;-)

Welche Details brauchst du genau? Ich habe das Programm jetzt als "normales" Update durchlaufen wollen aber auch hier sagt er, dass er das Update "vorbereitet" und danach kommt eine Meldung "0x800705b4". MSIs stellen aber am gleichen Rechner keine Probleme dar.

Getestet wird mit einem WSUS auf 2012R2 mit lokal installiertem WPP. Client ist ein Win10x64 Pro.

Viele Grüße,
Belloci
Jul 6, 2016 at 2:40 PM
Wenn Du exakt diese EXE auf dem Rechner manuell installieren möchtest, funktioniert es dann? Falls ja, leg die EXE in %windir%\SoftwareDistribution ab und starte die EXE aus einer administrativen Commandline heraus. Also nicht per Doppelklick starten, sondern per Commandline. Alles klar? Welcher AV-Scanner wird eingesetzt?

Ein paar Artikel gibt es zu dem Problem, zwei gehen in die gleiche Richtung:
http://www.win-10-forum.de/windows-10-updates-and-patches/546-win-10-laedt-keine-updates.html
http://www.borncity.com/blog/2015/11/11/windows-10-update-error-0x800705b4/
Sind die verwendeten Treiber auf dem System aktuell?


Und hier gibt es auch noch einen Lösungsvorschlag:
https://www.thegeneralistit.com/blog/2015/10/02/fixing-windows-10-update-error-0x800705b4/

Ist das ein clean Install oder ein Inplace Upgrade von einem alten OS?
Jul 6, 2016 at 2:53 PM
Edited Jul 7, 2016 at 5:59 AM
Hallo Winfried,

2 der URLs kannte ich schon... Also die exe aus %windir%\Softwaredistribution einer adm. Commandline funktioniert. Es kommt hier der AV-Scanner von TrendMicro (OfficeScan) zum Einsatz.

Die verwendeten Treiber sollten aktuell sein. Hier handelt es sich um eine virtuelle Maschine (VMWare). Aber auch Blech verhält sich analog dazu.

Ja, es ist ein Clean install mit aktuellstem WIn10 1511 (10586.420)

Ich sehe das Update auch im Taskmanager (die Exe steht in den aktuellen Prozessen) PrintDesktop.exe. Jedoch passiert nichts und das Update Fenster zeigt, dass das Update "vorbereitet" wird - bis es zu einem Fehler irgendwann kommt...


Viele Grüße,
Belloci
Jul 6, 2016 at 3:41 PM
OK, funktioniert es denn auf einem 32-Bit W10? Oder auf W8.1 oder auf W7? Wenn es auf W7/W8.1 via WPP/WSUS funktioniert, hat MS hier wohl etwas 'angepasst'. Alternativ könntest du natürlich eine MSI selbst erstellen. Hab ich selbst aber schon sehr sehr lange nicht mehr gemacht, also auch keine Erfahrung mit aktuellen Tools dazu.
Jul 7, 2016 at 6:09 AM
Morgen Winfried,

also W7 verhält sich ähnlich... Kann es sein, dass sich die Exe einfach nicht verteilen lässt, weil das Setup auf Eingaben "wartet"?! Wie gesagt, im Task-Manager sehe ich die Exe des Setups aber es tut sich einfach gar nichts. Ich denke, dass das Setup dann in ein Timeout läuft und beendet. Kennst du zufällig ein Programm, welches sich im Form einer exe ohne Probleme verteilen lässt? Dann würde ich damit die Gegenprobe anstellen...


Viele Grüße,
Belloci
Jul 7, 2016 at 7:01 AM
So etwas ähnliches dachte ich mir schon fast. Gibt es denn sog. Silent Schalter für die EXE? Via Start > Ausführen > Pfad_zur_Exe /? aufrufen. Bekommst Du Silent Schalter angezeigt? Wenn nein, Hersteller der SW danach fragen.

Alternativ nochmal der Hinweis auf ein Tool, das aus der EXE ein MSI erstellt.

Du kannst diese EXE zum Test verwenden: http://wsus.de/uninstall2install Läuft bei mir und vielen anderen immer ganz problemlos.
Marked as answer by Belloci on 7/7/2016 at 2:21 AM
Jul 7, 2016 at 7:06 AM
Hi Winfried,

also ich glaube dann können wir diesen Thread hier schließen, es wird dann wohl daran liegen. Den Test werde ich mit Sicherheit noch machen (uninstall2install).

Es wäre ein Segen, einen guten MSI-Wrapper zu kennen aber alles was ich bisher probiert habe war nicht so erfolgreich...

Den letzten Test werde ich noch hier Posten.

Danke für deine Hilfe!! :-)

Gruß,
B