[Closed] 7z920-x64.msi installed in to %ProgramFiles(x86)% folder

Topics: Publishing Issue
Oct 9, 2013 at 12:16 AM
I am trying to publish 7-Zip.
I have no problem with the 32-bit version. (I add a rule that only allows install on 32-bit OS)
When I do the same with the 64-bit version, the program installed OK but in the Program Files (x86)\7-Zip folder and will not work properly as the program looks for components in the Program Files\7-Zip folder.
If the install the program by just double clicking the msi file and following the prompts, everything works perfect.
If it install the program from a command prompt as follows: msiexec /i 7z920-x64.msi /q
it also works perfect.
But when I installed it via WPP and only add the rule Processor Architecture = x64 to the determine if the update is installable page, it gets installed into the Program Files (x86)\7-Zip folder.
I even tried adding INSTALLDIR="%ProgramFiles%\7-Zip" to the Command Line option, still no luck.
Oct 9, 2013 at 6:45 AM
Please, verify that you don't have publish the 32-bit version twice.
Try to revise the update and check the option 'Can request user input'.
Marked as answer by DCourtel on 9/13/2014 at 12:44 PM