[Solved] Failed to Sign Package

Topics: Configuration Issue, Publishing Issue
Nov 5, 2013 at 1:39 AM
I am totally lost. I had it working, upgraded to the new version and now nothing. I removed all certificates. Rebooted. Created a new certificate using Package Publisher, Rebooted. and still get the error. I switched back to the old version and nothing.

I am running Server 2012 and the latest version of Package Publisher. Please help!!!!
Coordinator
Nov 5, 2013 at 5:42 AM
What error do you get ? When does this error appears ? What are you doing to get this error ?
Nov 5, 2013 at 2:19 PM
I run the program and generate the certificate. Save the certificate and restart the computer. Once it reboots I open MMC and verify that there is a certificate in the WSUS, Trusted Root, and Trusted Publishers folders.

I launch WPP and attempt to create an update. I use the simple tutorial of the Adobe Reader 11.05 msp. It gets to the last step where it builds and publishes the update and I get the error Failed to sign the package: 2148081670

I have removed the certificates from the mmc rebooted and tried the process again. I even went as far to reinstall the server from scratch and still nothing. I know it is a Certificate error, but I can't figure out what I am doing wrong. I have read and reread the directions and I still get the same error.

I even tried downloading updates packages from Adobe using the import tool. It downloads and fails with the exact same error.

I appreciate your help.

Anthony
Editor
Nov 5, 2013 at 3:14 PM
You have to Import this certificate into the trusted Publishers and trusted root certification store.

Regards
Norbert
Nov 5, 2013 at 3:51 PM
I did import it into both locations for on the local computer and verified that they are there with MMC.
Coordinator
Nov 5, 2013 at 4:56 PM
Can you send me by mail the Options.xml file (it is in the same directory that the exe) at package.publisher@free.fr
Coordinator
Nov 5, 2013 at 7:22 PM
Are you using a self-signed certificate or a certificate issued by your own Root Authority ?
Can you check your certificate deployment against this board :
Checking Certificate deployment

If you have rebuild the server, remember that dropping the cert into the "Wsus" store is not enough. You have to import it through WPP.
Nov 5, 2013 at 9:50 PM
It is in the correct places. I allowed WPP to build the Self Signed Certificate and ensured it was each of the locations above. WPP is running on the server.
Coordinator
Nov 5, 2013 at 10:17 PM
Does the certificate is in the 'Computer stores' or 'User stores' ?
Nov 5, 2013 at 10:35 PM
Computer

Anthony Volpe
IT Instructor
Atlantic County Institute of Technology
5080 Atlantic Avenue
Mays Landing, NJ 08330
Ph: 609-625-2249 x7607


Coordinator
Nov 7, 2013 at 8:10 PM
If you have reinstall the Wsus server, generate a new self-signed certificate with WPP and check that all cert are in the right place... I'm little bit lost.

If you want I can take a look at your Wsus server by a Teamviewer session. Send me an email at package.publisher@free.fr in this case.
Marked as answer by DCourtel on 1/17/2014 at 8:08 AM
Nov 14, 2013 at 9:49 AM
I am having the same issue like described in this post. All certifices (self-signed) are installed correctly like described here. If try to publish an update I'll get this error message. Anyone have a solution for this issue right now?
Nov 14, 2013 at 12:56 PM
I still have not gotten it working, but I have not had much more time to test.

Anthony

Anthony Volpe
IT Instructor
Atlantic County Institute of Technology
5080 Atlantic Avenue
Mays Landing, NJ 08330
Ph: 609-625-2249 x7607


Nov 26, 2013 at 2:02 AM
Is is possible to create a WSUS Code Signing certificate from a Stand-alone CA? I am not sure how to create the request to process on the CA.

Anthony
Coordinator
Nov 26, 2013 at 5:51 AM
Yes, you can import your own code signing certificate from your own CA. In the documentation, you will find an article in English. I suppose you can find many tutorials on this subject on Internet.
Nov 26, 2013 at 1:43 PM
The tutorial I found online indicates that you need an Enterprise CA, I have a stand alone CA configured that is trusted by my domain. I am not sure how to generate the request file to start the process.

Anthony

Anthony Volpe
IT Instructor
Atlantic County Institute of Technology
5080 Atlantic Avenue
Mays Landing, NJ 08330
Ph: 609-625-2249 x7607


Coordinator
Nov 27, 2013 at 9:30 PM
I don't have enought experience on Certificate Authority to give advice. You may expect some help from WPP's users. But you should try your luck on other forums, like technet.
Editor
Nov 29, 2013 at 4:58 AM
Dec 18, 2013 at 10:27 AM
Edited Dec 18, 2013 at 10:30 AM
Hi,
I use a WS2012 Enterprise CA and it works fine, I issued a 'Code Signing' certificate and followed the rest of the guide.
Guide link

Works with WSUS on a WS2012 and newest WPP version.
Coordinator
Dec 18, 2013 at 7:26 PM
Good to know.