This project has moved and is read-only. For the latest updates, please go here.

[Solved] How WSUS Package Publisher Handles Older Versions

Topics: Misc., Publishing Issue
Nov 28, 2013 at 12:00 AM
Hi,

We are playing about with WSUS Package Publisher and so far everything is great. But we want to make sure that if a user has manually installed a NEWER version of a program

For example, our users are running Adobe Reader Ver 7. I create a Package to install Ver 8, however, some users have manually installed Ver 9. Will the package fail on the machines that are running version 9, or will it remove version 9 and put version 8 on instead?

I did a quick test and noticed that the package appears on my install list, but whenever i do the install i get the error 80070643

Thanks
Nov 28, 2013 at 8:09 PM
Edited Dec 12, 2013 at 6:07 AM
Hi,
You need to make rules to ensure that older versions appears as 'Non Applicable'.
If you are publishing MSI/MSP files, this should be already the case.
If you are publishing EXE files, you can use rules based on registry key to achieve this.
Marked as answer by DCourtel on 1/17/2014 at 7:57 AM