This project has moved and is read-only. For the latest updates, please go here.

[Solved] Crash on 'Publish'

Topics: Publishing Issue
Feb 5, 2014 at 10:00 AM
Edited Feb 5, 2014 at 10:01 AM

I'm trying to redefine rules for Flash Plugin deployments - as of today I use the predefined 'installable' rule & add a 'WindowsVersion' rule to define the 'ProductType'. This works without a hassle but: the update shows as needed even on machines where e.g. Firefox is not installed.

Now I've tried to to add a 'FileExists' rule with the only parameter "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" - pressing 'Publish' crashes WPP. This happens , too, if I revise an existing Package & try to modify the rule ...

Can't see my error, any help appreciated ;)

Feb 5, 2014 at 8:03 PM
start WPP, do exactly the same things. After crash, go to %temp% and find the file Wpp-GUID.log. Send it to me at
Feb 6, 2014 at 8:11 PM
Hi, thank you for the debug file.
When you have add the 'File Exists' rule, do you have put the filepath between quotes : " C:\Program Files (x86)\Mozilla Firefox\firefox.exe "
If yes, remove it. Wpp will take care of spaces in the path.
Marked as answer by DCourtel on 2/6/2014 at 1:13 PM
Feb 6, 2014 at 8:55 PM
... strange - but great: removing the double quotes from the path did the trick - update successfully revised & published. I've really overlooked the double double quotes in my attempts. Perhaps this should be mentioned anywhere in help/explanation window ...

Thankx & regards