This project has moved and is read-only. For the latest updates, please go here.

Error publishing Adobe Acrobat 9.1.0 MSP

Topics: Publishing Issue
Mar 25, 2014 at 11:02 AM
Edited Mar 25, 2014 at 11:02 AM
Hi everybody,

I am trying to publish Adobe Acrobat 9 updates. As these are not cumulative I need to start from 9.1.0 up to 9.5.5...

Regardless which of the updates I try to publish, I always get the "Ooops, somthing went wrong" box with the following error after hitting the "Publish" button:
**** The 'http://www.microsoft.com/msi/patch_applicability.xsd:TargetLanguage' element is invalid - The value '0,1033,1036,1031' is invalid according to its datatype 'http://www.microsoft.com/msi/patch_applicability.xsd:ValidateLanguage' - The string '0,1033,1036,1031' is not a valid Int32 value.
The 'http://www.microsoft.com/msi/patch_applicability.xsd:TargetLanguage' element is invalid - The value '0,1033,1030,1035,1044,1053' is invalid according to its datatype 'http://www.microsoft.com/msi/patch_applicability.xsd:ValidateLanguage' - The string '0,1033,1030,1035,1044,1053' is not a valid Int32 value.
The 'http://www.microsoft.com/msi/patch_applicability.xsd:TargetLanguage' element is invalid - The value '0,1033,1036,1031' is invalid according to its datatype 'http://www.microsoft.com/msi/patch_applicability.xsd:ValidateLanguage' - The string '0,1033,1036,1031' is not a valid Int32 value.
The 'http://www.microsoft.com/msi/patch_applicability.xsd:TargetLanguage' element is invalid - The value '0,1033,1043,1040...
Any ideas would by appreciated.

Regards
Robert
Mar 27, 2014 at 5:42 PM
The error message seem to show that there is a problem with the MSI/MSP file you try to publish. XML rules in the file cannot be validate by the xsd.
This error message is provide by the Wsus server, so I can't do anything to avoid that. Try with other files.
Marked as answer by DCourtel on 5/8/2014 at 2:44 AM