This project has moved and is read-only. For the latest updates, please go here.

Adobe Reader "not applicable"

Topics: Publishing Issue
Jan 30, 2015 at 8:37 AM
Good morning,

since a few day i testing with WPP Release v1.3.1411.09 on a Server 2012R2 with several downstreamservers. The installation and configuration of WPP were without any problems.
Testing with deployment of Flashplayer and Firefox were also without any problems.
Thx for that great piece of software!

Now my issue:
I tried to deploy Adobe Reader. I used the import via catalogue and imported the updates (non MUI) for Adobe Reader 11.0.01 -> 11.0.10. Everything fine till here.
I approved all the updates for my Testgroup. In that testgroup are 2 Clients installed from our WDS and after install they got Adobe Reader 11.0.00 via Distribution from GPO. Addional they got updates from GPO-Distribution till version 11.0.07.
Now in the 1st test from WPP they got the Update for Version 11.0.08 ... everything fine.
But for the two following updates (11.0.09 and 11.0.10) i got the info "Not Applicable".
I tested a little bit arround and also approved all the 10 updates ... now the weird thing is:
Windowsupdate offering these testclients the updates 11.0.02 and 11.0.05 (in one step).
... Confusing ... just for fun i tried to install them ... that failed ... OK.

Then i tried also to download and publish them manual (not from catalog) without luck.
So i am now out of ideas ...
How can i check whats wrong ... ? How can i deploy these update to my 500 Clients which
installed in the same way like described with installed AR 11.0.07?

My Target is to use only WPP in the Future. No more GPO-Distribution.

best regards
Feb 2, 2015 at 1:54 PM
no Idea?

Feb 2, 2015 at 9:22 PM
Two things :
  • Don't mix deployment methods.
  • Applicability status are evaluate by Windows Update Agent by looking at "IsInstalled" rules and "IsInstallable" rules. In case of update from Catalog, these rules are authored by the editor of the MSI/MSP file.
When you publish an update from a catalog, you can revise the update to see what applicability rule is Embedded.
Feb 3, 2015 at 2:17 PM
Thanks for your post!

For the previous installations via GPO every time i downloaded the EXE
uncompressed it and patched the msi with the msp file with the command:
msiexec /qb /a F:\AR\AIP\AcroRead.msi /p F:\AR\ARFiles\AdbeRdrUpd1100X.msp

Now our clients have these update in version 11.0.07 installed via GPO.

What would be the right way to create updates for the WPP which can be installed
on the clients with the above described installed Version 11.0.07?

Feb 4, 2015 at 1:26 PM
I made a new try:

i build an package like the previous packages...
first made an administrative Installation of the msi 11.0.0 and then:
msiexec.exe /a AdbeRdr11000_de_DE.msi /p AdbeRdrUpd11010.msp

The directories of the administrative installtion and msi + mst files i added to the new update for publishing.
At the last step before publishing i got an error message about the pathlength but the update will published
When i check the status my clients say "Installed" without installing the update. so it will also not displayed
for installation ....

I am really out of ideas atm .... anyone can help?