This project has moved and is read-only. For the latest updates, please go here.

can`t connect to local server

Topics: Configuration Issue
Jul 8, 2016 at 8:07 AM
Edited Jul 8, 2016 at 8:07 AM

i recently installed a new wsus server and of course the WSUS Package Publisher.

Although i can connect to the server when i uncheck the "connect to local server" checkbox, i can`t connect to the server locally.

The error message:
Connection failed: Invalid URI: The hostname could not be parsed.
I tried to use IP-Address or fqdn instead of the hostname but it did not worked.
Ping to the hostname resolves the ip address correctly.

I have found this post but i cannot imagine what registry setting the guy meant:

My WSUS Server is installed on a fresh Server 2012R2 with SSL activated and i use Port 8531 to connect to the server.

My options.xml:
Jul 8, 2016 at 8:28 AM
The Registry Settings should be this: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup

Is WPP installed on the WSUS? The WSUS.MSC ist working? Did you install KB3159706 on your WSUS? If yes, did you alle the manually Steps?

Pls post a image with Settings from your WSUS in WPP-Settings.
Jul 8, 2016 at 8:29 AM
Try Port 443 fro SSL.
Jul 8, 2016 at 8:58 AM
Here is the picture:


i changed the port in the registry to 443 and in the iis/wpp too.

error message changed to:
Connection failed:
The underlying connection was closed: could not establish trust relationship for the SSL/TLS secure channel
Jul 8, 2016 at 9:01 AM
Sorry, my fault. In the Registry don't change anything. Change back to 8531 in Registry.

Change from 8531 to 443 in your Options.xml. Pls close before your WSUS.
Jul 8, 2016 at 9:05 AM
New error:
Connection failed: Unable to connect to remote server
Jul 8, 2016 at 10:08 AM
Hmm, you changed back in registry to Port 8531? Can you connect with WSUS.MSC? You changed onyl in options.xml? Restart the whole server.
Jul 8, 2016 at 10:19 AM
Yes, i revert the changes to the registry.
I can connect to the wsus.msc

I changed the port in the options.xml, in iis binding and the gpo.

You mean i have to stay everywhere on port 8531 except wpp?
Jul 8, 2016 at 10:53 AM
I found a solution.

i recreated the wsus certificate with the fqdn as cert name and now it works, even with port 8531 in options.xml.

Tank you for your help :)
Marked as answer by mi271 on 7/8/2016 at 2:53 AM