Some OUs stopped making status reports

Topics: Publishing Issue
Aug 17, 2016 at 7:06 AM
Edited Aug 17, 2016 at 7:39 AM
Hello everyone,

first of all I'm not sure if that is in the right topic.

I've started using the Wsus Package Publisher around the 6th of July. The configuration and deployment of self created packages worked fine. I tested this with a special OU, where my and some other test PCs are members of.

Sadly, every PC from 3 different OUs stopped transmitting status reports. The last submitted reports are from the 6th of July (where the WPP was firstly configured and used).

We are using the WSUS Build 6.3.9600.18228, OS is Windows Server 2012 R2 Standard.

Here is an interesting part of a problematic client's Windows Update log:
2016-08-16  07:00:49:371     572    1344    PT  WARNING: Cached cookie has expired or new PID is available
2016-08-16  07:00:49:371     572    1344    PT  Initializing simple targeting cookie, clientId = 5874a2e0-8020-43d3-ba92-b7b22b3df2de, target group = NL Clients Windows 7, DNS name = 013218wi7.ads.europart.net
2016-08-16  07:00:49:371     572    1344    PT    Server URL = http://wsus01:8530/SimpleAuthWebService/SimpleAuth.asmx
2016-08-16  07:00:49:496     572    1344    PT  WARNING: GetCookie failure, error = 0x8024400D, soap client error = 7, soap error code = 300, HTTP status code = 200
2016-08-16  07:00:49:496     572    1344    PT  WARNING: SOAP Fault: 0x00012c
2016-08-16  07:00:49:496     572    1344    PT  WARNING:     faultstring:Fault occurred
2016-08-16  07:00:49:496     572    1344    PT  WARNING:     ErrorCode:ConfigChanged(2)
2016-08-16  07:00:49:496     572    1344    PT  WARNING:     Message:(null)
2016-08-16  07:00:49:496     572    1344    PT  WARNING:     Method:"http://www.microsoft.com/SoftwareDistribution/Server/ClientWebService/GetCookie"
2016-08-16  07:00:49:496     572    1344    PT  WARNING:     ID:1988f633-1433-498a-b674-04fb31398c87
2016-08-16  07:00:49:543     572    1344    PT  WARNING: Cached cookie has expired or new PID is available
2016-08-16  07:00:49:543     572    1344    PT  Initializing simple targeting cookie, clientId = 5874a2e0-8020-43d3-ba92-b7b22b3df2de, target group = NL Clients Windows 7, DNS name = 013218wi7.ads.europart.net
2016-08-16  07:00:49:543     572    1344    PT    Server URL = http://wsus01:8530/SimpleAuthWebService/SimpleAuth.asmx
2016-08-16  07:01:08:100     572    1344    Agent   WARNING: Failed to evaluate Superseded rule, updateId = {8FB961A9-DB99-4FC6-B7A8-6487B0670B33}.3, hr = 8024E003
2016-08-16  07:01:29:995     572    1344    PT  +++++++++++  PT: Synchronizing extended update info  +++++++++++
2016-08-16  07:01:29:995     572    1344    PT    + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://wsus01:8530/ClientWebService/client.asmx
2016-08-16  07:01:30:057     572    1344    PT  WARNING: GetExtendedUpdateInfo failure, error = 0x8024400E, soap client error = 7, soap error code = 400, HTTP status code = 200
2016-08-16  07:01:30:057     572    1344    PT  WARNING: SOAP Fault: 0x000190
2016-08-16  07:01:30:057     572    1344    PT  WARNING:     faultstring:Fault occurred
2016-08-16  07:01:30:057     572    1344    PT  WARNING:     ErrorCode:InternalServerError(5)
2016-08-16  07:01:30:057     572    1344    PT  WARNING:     Message:(null)
2016-08-16  07:01:30:057     572    1344    PT  WARNING:     Method:"http://www.microsoft.com/SoftwareDistribution/Server/ClientWebService/GetExtendedUpdateInfo"
2016-08-16  07:01:30:057     572    1344    PT  WARNING:     ID:2d17ebcc-d388-4eb5-baa6-9c88920fb8eb
2016-08-16  07:01:30:057     572    1344    PT  WARNING: PTError: 0x8024400e
2016-08-16  07:01:30:057     572    1344    PT  WARNING: GetExtendedUpdateInfo_WithRecovery: 0x8024400e
2016-08-16  07:01:30:057     572    1344    PT  WARNING: Sync of Extended Info: 0x8024400e
2016-08-16  07:01:30:057     572    1344    PT  WARNING: SyncServerUpdatesInternal failed : 0x8024400e
2016-08-16  07:01:30:073     572    1344    Agent     * WARNING: Exit code = 0x8024400E
2016-08-16  07:01:30:073     572    1344    Agent   *********
2016-08-16  07:01:30:073     572    1344    Agent   **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates]
2016-08-16  07:01:30:073     572    1344    Agent   *************
2016-08-16  07:01:30:073     572    1344    Agent   WARNING: WU client failed Searching for update with error 0x8024400e
2016-08-16  07:01:30:073     572    a40 AU  >>##  RESUMED  ## AU: Search for updates [CallId = {8D739C7B-44F3-4E42-A8A3-659FF19F1F6E}]
2016-08-16  07:01:30:073     572    a40 AU    # WARNING: Search callback failed, result = 0x8024400E
2016-08-16  07:01:30:073     572    a40 AU    # WARNING: Failed to find updates with error code 8024400E
2016-08-16  07:01:30:073     572    a40 AU  #########
2016-08-16  07:01:30:073     572    a40 AU  ##  END  ##  AU: Search for updates [CallId = {8D739C7B-44F3-4E42-A8A3-659FF19F1F6E}]
2016-08-16  07:01:30:073     572    a40 AU  #############
And here from the SoftwareDistribution log from the server:
2016-08-16 06:48:12.877 UTC Warning w3wp.38 SoapUtilities.CreateException   ThrowException: actor = http://wsus01:8530/ClientWebService/client.asmx, ID=a8fc058d-2de3-4691-8aee-0904b05974c6, ErrorCode=InternalServerError, Message=, Client=22b5e3d3-b10d-49cc-94a4-97bb241c5570
2016-08-16 06:50:42.221 UTC Error   w3wp.13 ClientImplementation.GetExtendedUpdateInfo  System.ArgumentException: The database does not contain a URL for the file 7E1786094E4CA9EA156CAECDB91FAF8D3E387146.
Parametername: fileDigests
I have declined all self created updates from WPP in WSUS and deleted the updates and products in the WSUS Package Publisher.

I also did not publish the updates to any OUs other than my Test one.

Is it maybe a certificate issue? We distributed the certs via group policy.
All clients also download updates from the Internet, not from the replicate server itself.

Does anyone have an idea what's causing that and how to resolve it?

Thanks in advance!
thatoneguy
Coordinator
Aug 17, 2016 at 8:02 PM
Hi, error code 0x8024400D means : SOAP_E_CLIENT  The message was malformed or incomplete. No reason to retry unless problem fixed.
error code 0x8024400E means : The message was OK but server couldn't process at the moment. Same message may succeed at a later time.
2016-08-16 07:00:49:496 572 1344 PT WARNING: ErrorCode:ConfigChanged(2)
Do you have installed any updates that may have changed Wsus config ?

These two messages let me think that something is «broken» your wsus server. See what changes on this server. May be on the Windows event log.
Is it maybe a certificate issue?
No, certificat is only involved into signing package, not communications between server and client.
Aug 18, 2016 at 7:55 AM
Hey, thanks for the response. Some updates were installed on the 7th of July, but the problems started already on the 6th. And the last updates installed before that were on the 30thth of June. So that shouldn't be the cause.
The only thing reported in the event viewer is an error from the wsus management console itself (System.Threading.ThreadAbortException). It appeared twice on the 6th and then it stopped appearing.
Aug 19, 2016 at 12:40 PM
So, I have reset the WSUS by following these instructions here
https://social.technet.microsoft.com/Forums/office/en-US/0119f29b-729e-469d-85b4-7d1e547ebe2d/how-to-completely-remove-wsus-on-windows-2012-r2?forum=winserverwsus

The clients are transmitting status reports again. It is still doing its first sync, but so far it's looking good again. Not sure what exactly caused this - maybe a corrupt database, maybe something else.
Marked as answer by thisoneguy on 8/19/2016 at 5:40 AM