This project has moved and is read-only. For the latest updates, please go here.

failed to load the certificate

Topics: Configuration Issue
Dec 14, 2016 at 7:28 PM
Following the official documentation and I am getting that error when trying to import my code signing certificate into WPP. The only difference from the the guide and my setup is I am generating the code signing cert on an intermiadate CA which the Root CA trusts.

Our Root CA is powered down and at this point I have no idea where it's at. I imagine it was powered on long enough to generate whatever certs the previous admins here needed and powered off after.

Not sure what else I am missing. I generated the cert, exported it, created a GPO and imported the cert. Applied the GPO to an OU where my WSUS server lives, ran gpupdate /force, logged off and logged back in. Confirmed via the Certificates MMC that the certs are in the trusted publishers store. Trying to import it to WPP gives me the error above. I've also tried removing the cert from the WSUS cert store and importing just through WPP but Im getting the same error.

Anyone have any idea what I'm doing wrong? I'd rather not use a self signed cert.
Marked as answer by liabt on 12/15/2016 at 8:18 AM
Dec 15, 2016 at 4:18 PM
ignore this. I found the solution in a different post. Just checked the ignore certificate verification.... on the settings section.
Dec 16, 2016 at 4:37 PM
The question is why the validation has failed?! Is it possible to get debug log for this Action, Import a certificate?
Jan 9, 2017 at 9:18 PM
If I do so - ignore - I can't create any update with function.